SEED가 IETF RFC로 등장

감자옹과 SPF에 대해 담소를 나누던 중, 최근에 RFC로 등록됐다는 SMTP 메시지 추적 확장판이 몇번인지 한번 찾아보려고, 오랜만에 RFC 인덱스를 끝에서부터 뒤져 봤습니다. 옛날에 호기심 많던 젊은 시절(-.-)에는비교적 자주 RFC 인덱스를 업데이트해서 봤었는데 훈련 다녀 오고서는 마냥 잠만 와서~ 크흐흐;;;

마지막부터 차근차근 보다가 아앗! 발견한 것이 RFC4009: The SEED Encryption Algorithm! SEED가 정말로 내가 4년 전에 회사에 갓 들어와서 아무것도 모를 때 하던 그 SEED가 맞는가 하고 잠시 고민을 했는데 옆에 한국식 저자명들이 아 그게 맞구나 하고 확신을.. 🙂 KISA에서 썼군요

전에 봤던 두툼한 책 2권짜리 수식으로 가득찬 SEED 책보다는 훨씬 얇아서 약간 주춤하기는 했는데, 기본 암호화, 복호화 방법과 매직넘버는 모두 담겨있어서 구현을 위한 최소한의 것은 잘 씌여 있군요. 수학식에 압도당해서 보기도 힘들었던 그 책 대신 이걸 봤으면 좀 더 쉽게 구현할 수 있었을지도..ㅠ.ㅠ

부록으로 RFC4010으로 CMS에서 사용하는 방법도 등록 되었네요.

그냥 보는 김에 쭉 위로 훑어보다가 작년 하반기 이후에 등록된 재미있는 것들이 제법 있었습니다. 흐흐

  • RFC3986에 URI가 새로운 버전으로 업데이트 되고, 오랫동안 draft 상태로 있었던 IRI가 RFC3987로 드디어 proposed standard로 등록되었습니다. (IRI는 URI에서 유니코드를 쓰기 위한 확장)
  • RFC3912로 WHOIS 프로토콜이 업데이트 되었습니다. 워낙 간단하니 별로 프로토콜에서 달라진 점은 안 보이고, 국제화에 대해서 대책이 없다는 것을 솔직하게 적은 게 추가 됐네요. (….)
  • 지금까지 IETF RFC로 등록된 적이 없었던 CGI가 역사를 기록이라도 하려는 듯 2004년 10월에서야 RFC3875로 등록됐군요. 요새 제가 쓰던 CGI들이 다들 레퍼러 스팸 공격을 받고서는 죽고 있어서 CGI는 이제 안 쓰려고 마음먹었습니다. ㅠ.ㅠ
  • 지나가다가 또 다른 한국식 이름을 발견했는데, RFC3974 IPv6 전환의 애플리케이션측 양상에 ETRI 소속의 한국인 저자가 첫번째부터 세번째까지 저자 이름이 올라가 있군요. 🙂 그리고 NetBSD의 itojun씨도 공동저자로! (와!)

요새 등록되는 RFC에 유독 SIP관련 내용이 많은 걸로 봐서는, 아무래도 인터넷 전화나 W-CDMA를 준비하는 업체들이 많이 보이는 것 같기도 하고 그렇네요. 그리고 그새 1월에 RFC4000을 돌파했는데.. 아직 RFC4000이 등록이 안 된것이.. 아무래도 만우절 농담을 RFC4000으로 등록하려는 것일까요? ;;; 4004도 비워놨고.. 뭐가 등록될 지 기대가 되는군요. 🙂

4 thoughts on “SEED가 IETF RFC로 등장”

  1. RFC3995부터 RFC4000까지가 비어 있는 걸로 봐서 뭔가 나중에 마구 들어 갈 예정인 모양이군요. (몽창 들어 간 것들이 죄다 만우절 농담이라면 초난감)

  2. 어랏!
    오픈룩이 엄청 바뀌었군요!!!

    여하튼… 덕분에 SPF라는 묘한 방법을 배웠습니다. 딱히 뾰족한 해결책 같지는 않지만… 가장 현실적인(당장 적용가능한) 해결책임에는 분명한듯 하네요~..~

    그나저나… 죄송한 얘기지만… 예전 오픈룩이 더 정감있었던거 같아요…-O-

  3. 드디어 URI RFC가 업데이트 되어 “/test”에 대한 “?foo” 상대 경로가 “/test?foo”로 고쳐졌군요! 이게 RFC 1808일 때의 정의였는데 RFC 2396으로 바뀌면서 상대경로 예제에 버그가 들어갔습니다. (orz) 모질라는 이 RFC가 draft 상태일 때부터 저자들과 의견 교환으로 이미 이렇게 하고 있었고, IE와 Opera는 이른 버전은 RFC 1808 (그리고 현재 RFC) 처럼, 그리고 현재 쓰이는 대부분의 버전은 RFC 2396 식으로 “/?foo”로 처리합니다. 결국 href=”?query” 할 것을 (예컨대) href=”{PHP_SELF}?query” 하는 수밖에 없었던 것인데… IE 7이 나와도 이전 버전을 지원해야 할테니 어차피 별 의미는 없을려나요.

Comments are closed.